Reviews and questions about the entry-level MPC500
By chester17 Tue May 14, 2019 1:31 am
I recently bought a used mpc500 off a guy and it worked perfectly fine while he was showing me it worked and later after i took it home but the next day it started running really slow and would take about ten minutes to load samples, after that it stopped loading the samples at all, when i got to the file part of the load program menu there would be nothing there. I've updated the os to the current version and ive changed the cf card and so far the mpc seems to be running faster but it still won't load samples. Another problem i've run into is that the machine wont factory reset, when i turn the machine on while holding erase it just goes to the erase menu. It has the standard ram card right now but im not sure if getting a new ram card will solve my problems.
User avatar
By Ill-Green Wed May 15, 2019 3:08 am
What size CF card are you using?

What RAM are you using?
By chester17 Sun May 19, 2019 10:57 pm
Ill-Green wrote:What size CF card are you using?

What RAM are you using?

Im using an 8 gb cf card and the standard ram that the machine came with
User avatar
By DjDiskmachine Tue May 21, 2019 8:36 am
chester17 wrote:
Ill-Green wrote:What size CF card are you using?

What RAM are you using?

Im using an 8 gb cf card and the standard ram that the machine came with


The MPC500 is a 32bit system, therefore it doesn't support storage greater than 4Gb.
Either format the card as 4Gb or get a smaller one.
Cheers
User avatar
By Ill-Green Sat May 25, 2019 3:07 am
DjDiskmachine wrote:
chester17 wrote:Im using an 8 gb cf card and the standard ram that the machine came with


The MPC500 is a 32bit system, therefore it doesn't support storage greater than 4Gb.
Either format the card as 4Gb or get a smaller one.
Cheers


Word, 8GB is too large. I had a 1GB and it was fast with that. At 4GB, is the maximum without much lag.