Share your knowledge on these two classic MPCs
By amenbr02 Wed Mar 13, 2019 12:20 am
Sounds like the same issue I'm having. With the exception that thus far could never get scsi2sd to be recognized by my mpc3000.

mpc3000:
Vallixi
Previously used a internal zip without issue.
internal settings set to: multi sector transfer mode: off

scsi2sd:
v5
can connect via usb and change settings. all listed within this thread were tried
can see the activity light flash when mpc3000 is scanning hd
tried multiple sd cards

Not really sure what else to try?
By Spod Fri Aug 02, 2019 2:27 am
I've got a 5.5 scsi2sd external enclosure that connects directly to the scsi output on the 3000 and the 3000 can't see the drive. Any specific way you need to set up the scsi2sd utility?


- I formatted the scsi2sd in 700mb
- have enable scsi terminator ticked
- start up delay is 0

Do I need to power it? There' no option outside a usb cable.
Do I need to preformat the sd card?
User avatar
By JUKE 179r Fri Aug 02, 2019 1:52 pm
Normally the 50-pin SCSI ribbon cable powers the internally mounted SCSI2SD card reader. It may not connect power to it through the MPC3000's 25-pin external SCSI connector. Dunno....
Hopefully someone who knows more will chime in.
By vout Fri Aug 02, 2019 7:59 pm
The 3K should have termination power on the external connector. You can easily check with a meter - there should be 5v on pin 25 of the connector. My 3K works great with SCSI2SD V5.1 (internal or external connection) but I have not tried the new V5.5 (but theres one on the way so I will soon). It is supposed to be compatibe with all samplers.
User avatar
By JUKE 179r Tue Aug 20, 2019 9:59 am
The description says "No cables necessary".
It looks like it's powered via the SCSI DB25 connection.
By TrakLite070777 Wed Nov 20, 2019 10:31 am
JUKE 179r wrote:Here’s the pix of the SCSI2SD util on my Mac for my 3000LE’s internal SCSI2SD with a 2GB SD card.
Hope this helps others...
Image
Image
Image

Peace. Did you set all the "Device" sizes to 2gb on that 2gb SD card?
User avatar
By JUKE 179r Wed Nov 20, 2019 1:51 pm
Yes. I believe I did set it to 2GB.
By olivr Tue Nov 26, 2019 4:36 pm
Has someone with an unrecognized 5.1 SCSI2SD made progress ?

I have an Artmix Stratos dual SCSI adaptor (That works when connecting a ZIP100 through it).

Can a successful user of a 5.1 SCSI2SD share the brand and make of their SD cards ?

Also interested in the revision number displayed in your scsi-util revision field...

Cheers